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ECMS PURPOSE 
eCMS application provides staff access to review and handle documents that are 
part of an automated workflow business process. While much of the business 
process runs automatically, some types of errors and issues require review by 
staff. Documents that need staff review and action are placed in a message 
queue to be accessed and processed. Using the eCMS application, staff can: 

 Review and modify documents 

 View, Add or perform action such as Approve error codes 

 View , Add, Edit or Delete notes 

 View an audit trail of the message detailing its path in the workflow 

 Make decisions in real time such as Accepting or Rejecting a message 

 Pend a message in user’s inbox 

 Forward message(s) to another user or all users 

 Set the message(s) priority as high, normal or low 

 Users have the option to activate/deactivate the ability to add a 
comment while performing any of the following actions: (Pend, Forward, 
or Submit) a message 

   2



eCMS v105 Generic User Guide  

NAVIGATING THE INTERFACE 

PANELS 

eCMS main window is divided into 4 panels: 

 Inbox: Displays all eCMS nodes in the workflows for each trading 
partner. The number of messages in the queue displays in parentheses 
next to each eCMS node for review. Select an eCMS Node to view all 
messages in this inbox. 

 Message List: Displays all the messages the user is authorized to 
review with the ability to sort and filter the messages. View individual 
messages by double clicking the message itself in the Message List.  

 Message Panel: Displays the message to be reviewed or modified in 
the relevant form(s). A Message Panel can contain several tabs each of 
which carries data about the message being viewed. 

 Message Extensions Panel: Displays errors, notes and audit record.  

x 
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FLOATING PANELS 

The Message Extensions Panel is moveable to create more room on the screen 
where it is needed. It is possible to move the entire panel, or its individual tabs of 
errors, notes and audit record. This is helpful to create additional room to view a 
message in the Message Panel.  

 Move the whole panel to view as a new window.  Click the 
thumbtack on the Messages Extensions Panel and drag it in any 
desired area in the current screen, keeping you left mouse button down 
to move it as a separate window. 
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Message Extensions Panel moved to float as 
a separate window  
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 Move the whole panel and place it on any of the screen edges.  
Click and drag the panel with its 3 tabs, keeping you left mouse button 
and place it on the desired edge. This is helpful to view a large form and 
notes or errors simultaneously. 
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Move the whole panel and place it for
example on the left edge of the screen
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 Move a single tab in the Message Extensions Panel. Click the 
desired tab, keeping your left mouse button pressed and place it on the 
desired place on your screen. 

 

NOTE: You can c
close button on th
View menu. For e
to the View menu
Extensions Panel
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A Single tab (Audit tab) moved from
the Message Extensions Panel
 

 

lose every single tab in the Message Extensions Panel from the 
e Title bar and view it again by selecting every single tab in the 
xample if you close the Audit tab and want to view it again, go 
, select Audit item and it will be displayed again in the Message 
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MENUS 

File Menu 

 Page Setup: Control the set up and layout options of the active form 
for printing. 

 Print Preview: Show how the form looks when printed in number of 
pages. For more details refer to Printing Forms. 

 Print:  Print the active form. For more details on the Printing action 
refer to Printing Forms. 

 ReLogin: Use this tab to change the user or the server host.  You can 
also click the ReLogin button on the toolbar 

 Exit: Quit the application. 

View Menu 
 Standard Toolbar: Open the standard toolbar where you can view 

message, forward, pend or submit a message. Also to refresh, reload or 
relogin.  

 Full Screen: Open the form in the Message Panel in full screen. 

 Refresh: Use this tab to refresh the messages available in the Inbox.  
The Inbox will refresh automatically every time a message is submitted.  
You can also click the Refresh button on the toolbar. 

 Reload Tree: Use this tab to reload the trading partners, with their 
workflows and eCMS nodes. The Inbox tree will reload automatically 
whenever the application is opened.  You can also reload the tree 
through clicking on the Reload button on the toolbar. 

 Notes: Open the Message Notes Panel of the current message, 
where you can view the notes previously added or add a new note.  

 Errors: Open the Message Errors Panel of the current message, 
where you can view the errors previously added or add a new error.  

 Audit: Open the Message Audit Panel of the current message, where 
you can view an audit trail of the path of this message in the workflow.   

 Options: Prompts you a comment when you select the check box of 
any of the existing actions (Pend, Forward, and Submit). This comment 
is prompted once you perform any of the above actions on an opened 
message. 
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Message Menu 

 View: Open a message in the Message Panel Area for review. Also 
you can click the "Message" button from the toolbar. 

 Forward: Send the message to another ECMS user or to all users. 

 Pend: Save the message in your inbox to review it later. 

 Submit: Send the message to one of the output ports of the selected 
eCMS nodes. 

 Clear Filters: Clear filters of the messages headers for a selected 
eCMS node. . 

 Clear all Filters: Clear all the filters in the messages headers of all 
trading partners. 

 
Rules Menu 

  View/Delete: View all the rules that currently exist in a certain eCMS.  

  Add Rule: Add the “Rules” feature to automatically forward or pend 
incoming messages, with a certain condition that you specify to certain 
users.   
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SHORTCUT KEYS 
Keyboard shortcuts are available to facilitate quicker use of the application for 
advanced users. 

 F5: Refresh the messages available in the Inbox.  (The Inbox will 
refresh automatically every time a message is submitted.) 

 CtrL+E: Show the Errors Panel 

 CtrL+A: Show the Audit Panel 

 CtrL+N: Show the Notes Panel 

 CtrL+P: To Print 

 F11: To view a form in full screen 

 Alt+F4: To Quit the application 
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Chapter 2 Interacting with Messages 
 

In this chapter 

 

ng a Message 

 Getting Started

 Viewing a Message 

 Reviewing or Modifyi

 Viewing and Adding Errors 

 Viewing and Adding Notes 

 Viewing a Message Audit 

 Printing Forms 
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 GETTING STARTED 

LOGGING IN 

Enter the Username and Password provided to you by your system 
administrator.   

NOTE: Do not change the advanced specification unless advised by your system 
administrator. If you have problems while logging in, please contact your system 
administrator. 

 

BASIC PROCESS 

The basic steps to process messages are shown below.  Details for completing 
each of the steps are described in the following sections. 
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Interaction 
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View 
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Errors and 
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Figure 1⎯Pr
Modify 
Message, 
if desired 
ocessing Mess
Add Notes or
Error Types, 
 if desired 
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Select Action 
(e.g., accept, 
Reject) and 
Submit
  



eCMS v105 Generic User Guide  

UNDERSTANDING THE INBOX 

The Inbox shows all available messages the user has access to view and use.  
The Inbox can be refreshed by clicking Refresh on the toolbar, and they are 
automatically refreshed every time you complete an action on a message.  

Messages are organized by trading partners, workflows and human interactions.  
The Human Interaction components contain the actual messages requiring 
action. Each eCMS node has a unique purpose; one component may be 
responsible for message review, other for message adjudication, etc…. 

 

s
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UNDERSTANDING AND CUSTOMIZING THE MESSAGE LIST 

You can customize the view of messages by sorting, filtering and aligning the 
messages. 

Sorting 
Sorting the message to change the order they display in the Messages List. 

1. Select the column header you wish to sort by and then select the data type 
from the header drop down list. 

2. Click the header at the top of the Messages List and all the messages will be 
listed alphabetically. 

Filtering 
Filtering the messages is related to filtering the displayed messages in the 
Messages List according to a word or letter(s) that you enter in the header of the  
field. 

1. Enter a specific word or some characters in the header field, for example a 
specific username and only the messages with that username that will be 
displayed in the message List. 

2. Select Clear Filter item from the header drop down list that you entered 
characters in and all the messages will be displayed in the Messages List. 

Alignment 
You can customize the text in each column to align to the center, right, or left.  

1. Select the Alignment item from the header drop down list. 

2. Select either center, right or left and the messages will be listed according to 
your selection. 
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MESSAG
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The drop down list from where you 
can sort, filter or specific the 
alignment of the Message List 
 

E COLOR INDICATION 

in to the application, you may find that the messages have several 
hese colors indicate the followings: 

Red Color: Happens if the message crashed before or incorrectly 
closed. 

Blue Color: Happens if the message is pending to you.  
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VIEWING A MESSAGE 

SELECTING A MESSAGE 

1. In the Inbox message tree, select an eCMS node and all the related 
messages will be displayed in the Message List. 

2. Select a message from the Message List then click  View Message button 
in the toolbar. Or double click the message itself and the message will be 
displayed in the Message Panel. Also, you can right click the message and 
then select View. 
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REVIEWING OR MODIFYING A MESSAGE 

EDITING OR MODIFYING IN THE MESSAGE FIELDS 

You can not modify the data in the message without adding an error. You have to 
add an error to the message so that the following eCMS user sees it and be able 
to modify it. A field with an added error will be highlighted in orange color where 
you can edit in it. 

For more details about adding the error, refer to Add a Specific Error. 
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VIEWING AND ADDING ERRORS 
Common error types can be identified using the Errors Panel.   

VIEW AN ERROR 

1. Select “Errors” from the View menu to open the Message Errors Panel, or 
click the Errors tab in the Message Extensions Panel. 

2. Double click the error where the "Error Details" window will be displayed to 
view the error details and comments from the user who entered the error. 

 

3. Click the Show History button to view some details of the error like the 
Username, Status, Comment and Date Modified from the user who entered the 
error. 
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ADD A GENERAL ERROR 

Add an error to the message to explain the type of error found during review.   

1. Select “Errors” from the View menu to open the Message Errors Panel. 

2. Click the Add button to open the Error Details window.  

 

3. From the Code drop down list select an error code (the error codes are 
predefined by your system administrator). The details of the selected error 
will be displayed in their related fields. 

4. Select the error Status from the Status drop down list (the error status is 
predefined by your system administrator).  

5. Add a comment, if desired, in the Comment text box. 

6. Click OK.  
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ADD AN  ERROR FOR A SPECIFIC FIELD 

1. Select the field you want to modify. 

2. Right click it and select Add Error and the Error Details window will be 
displayed. 

 

3. Select the Error Code from the drop down list. Refer to your system 
administrator for questions about the error codes. 

4. Select the Error Status from the related drop down list. Refer to your system 
administrator for questions about the error status. 

5. Enter any notes or comments in the Comment text field. (Optional) 

6. Click OK, and then you can edit in the selected field, it will be highlighted in 
orange. 

NOTE: When you add an error on a certain field, this field will be highlighted in 
an orange color to show the next user that there is an error in this field. 

   20



eCMS v105 Generic User Guide  

VIEWING AND ADDING NOTES 

VIEWING NOTES 

1. Select Notes from View menu. 

2. Double Click the Note that you want to open and the Note Details window is 
displayed, showing the title of the note, the user who added the note, the note 
text, and any attachments. 

 

3. To view an attachment, select the attachment and click View button. 
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ADDING A NOTE 

1. Select Notes in the View menu and the Note Details window will be 
displayed. 

 

2. Click the Add button to open the Note Details window, to add a comment or a 
note to the currently open message.  

3. Enter the title of the new note in the Title field.   

4. Enter a note in the Body text box. 

5.  To add an attachment to the note, click the Add button in the Attachments 
section.  To remove an attachment, select it and click Remove. 

NOTE: The Save As button is disabled when you add an attachment, but it is 
enabled if another user adds the attachment 

DELETE A NOTE 

1. Select the note to be deleted. 

2. Click the Delete button. 
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VIEWING A MESSAGE AUDIT 
The audit details the path of the message.  View the audit to see a history of the 
path of the message in the workflow.  

1. Select Audit in the View menu to view the details of tracking the active 
message. 

2. You can view the component name that used that form in the workflow, along 
with the name of the user, and the date of the action performed on the form. 

3. In the Audit tab, you can see the comment that the user added upon the 
action performed (Pend, Forward, and Submit). 

NOTE: The username field of the Audit displays the name of the user who 
processed the message.  The name System is displayed for all automated 
activities. 
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PRINTING FORMS 
You can print a copy of any of the forms. 

PRINT PREVIEW 

Select Print Preview in the File menu and the Print Preview Window will be 
displayed. It is divided into two sections: 

 Scaling 

 Choose the Tabs to Print 

 

 

1. Select the desired Scaling, or Size.  Choose “Fit each tab to single page” if 
you want the form to fit on one page. Choose”Adjust each tab to” and select a 
percentage to increase or reduce the size.  

2. Choose the Tabs to Print by selecting the related radio buttons.  You can 
print the form of the currently selected tab, choose to print the forms from all 
tabs, or select a range of tabs to print. 

3. Click OK and the Print Preview page will display to show you how the form 
will look when printed. 
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PRINT 

1. Select Print item in the File menu and the Print window will be displayed.  

2. Click OK to perform the action or Cancel to cancel the action. 
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Chapter 3  Actions on Messages 
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PERFORMING ACTIONS ON A MESSAGE 
ages, select an action to execute. These 

ges. 

 

After reviewing and modifying mess
actions include: 

 Forwarding an open message 

 Pending an open message 

 Submitting an open message 

 Setting an open message priority 

 Closing an open message. 

 Forwarding/Pending/Submitting Multiple Messa

2

e 
e 
 

 View th
messa in 
a full scr

g
een
 7
 

 

Pend the 
message in your 
inbox 
FORWARDING

You can forw

1. Select a 
user, or s

2. Click  
Send the message to 
one of the output 
ports
 AN OPEN MESSAGE 

o

Figure 2⎯ An open 

ard a message to an

User from the Forward
end it to the larger gro

Forward and a confirm
Forward a 
message to 
another eCMS user
ther eCMS user or t

Message Toolbar 

 drop down list.  You
up by selecting ‘All U

ation message will b
Specify the 
message 
priority 
o All Users.  

 sp may select a
sers’. 

e displayed. 

 

Close the 
message 
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3. Click Yes if you are sure you want to send this me

PENDING AN OPEN MESSAGE 

Pending a message means saving

ssage to the selected user. 

 the message in your inbox to review it later.   

1. Open the message and it will be displayed in the Message Panel. 

2. Click the  Pend button to keep the message in your account and a 
confirmation window will be displayed. 

 

is message to the logged 
splayed. 

3. Click Yes if you are sure that you want to send th
user and the "Pending Reason" window will be di

 

1. Enter the Pending reason and then click OK. The pending reason will be 
 the message list panel. 

 the Message List.  

displayed as a tool tip to the selected message in

NOTE 1: When you pend a message, it will display in blue in

NOTE 2: You can disable the pending reason opt
Select Options and Uncheck the Pend checkbox   

ion from the View Menu, then 
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SUBMITTING AN OPEN MESSAGE 

When you submit a message you send it to one of the output ports of the 
selected eCMS node. 

. Select the Output port you want your message to go to from the related drop 
down list, for example Accept or Reject. 

1

 

2. Click  Submit and a Confirmation window will be displayed, 

 

3. Click “Yes” if you are sure you want to send this message to the specified 
 form. output port. Click No if you want to return back to the message
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DETERMINING AN OPEN MESSAGE PRIORITY 

You can determine the message priority that appears in the 

1. Open a message  

2. Select the message priority 

Messages Panel. 

 from the Priority drop down list in the message 
toolbar, and choose high, low or normal. 

3. e 
exclamation mark beside each message changes according to its priority: 
Messages with priority high have red exclamation mark whereas the low 

 the normal priority messages remain 
in blue. When the priority of messages is set the high priority messages are 

 
low priority are at the bottom part of the message list. 

When you are done with all actions on a message, you can close it by clicking 

The Message priority will be shown in the message list. The color of th

priority messages have grey color, while

sorted to be on the top of the message list, the normal in the middle and the

 CLOSING A MESSAGE 

the  Close button.  You cannot view another new message unless you clos
 current message. 

TE: The 

e 
the

NO  Close button in the message toolbar will be disabled before 
selecting any action on the message such as sending, submitting or pending it. 

FORWARD/PEND/SUBMIT MULTIPLE MESSAGES 

t Messages 

2. Click Forward icon 

Users can select multiple messages and Forward or Pend or Submit them 
simultaneously without having to open them.  

Forward/Pend/Submi
1. Select the messages you want to perform an action on from the Message List 

Panel. In order to select multiple messages at the same time, click Ctrl tab 
and then select the messages you want. 

 from the toolbar to forward the selected messages or 
click Pend  icon from the toolbar to pend
“Submit” 

 the selected messages or click 
 icon to submit the selected messages. 
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MANAGING 

oming messages, eCMS application can 
tly. You can use the “Rules” feature provided 

with

The f messages to certain 
users at once, based on predefined criteria, without having to open them one by 

 to certain users. For 
 incoming messages 

LARGE NUMBERS OF MESSAGES WITH RULES 
When you have large volumes of inc
help you process them more efficien
by the eCMS application to automatically forward or pend incoming messages, 

 a certain condition that you specify to certain users. 

THE PURPOSE OF THE M SAGE RULES 

 purpose  the rule is to be able to assign groups o

ES

of

one. Using rules, you can assign or pend certain messages
example you can create a rule, that assigns all existing and
whose SSN=’12345’ to a certain user “User1”. 

NOTE: The defined rules are not case sensitive, e.g., If the SSN value of the 
currently selected message is “123A” (this is the one that 
against), and a message is received with the SSN value “1

the rule will match 
23a”, this message 

will match the rule, and should go to the selected user as the rule specifies. 

MESSAGE RULES AND USER PRIVILEGES 

If we have four users: Admin (defined in the XIP Administrator as an 
administrator user), User1, User 2, User 3 (normal users). 

 The Administrator is the only user who can assign messages from a 
le 
er 

ign 
them to anyone else. 

 Another exam t, if the user “User1” creates a rule that, when 
t belongs to “User 2” to “User 3”. This 

rule will fail to apply because the rule creator (User 1) doesn’t have the 

ted by himself. If a 
le 

normal user to another. For example, if the user “Admin” creates a ru
that, when applies, assigns a message that belongs to “User 1” to “Us
2”. This rule will be successfully applied because the rule creator 
(Admin) has the right to take messages from a normal user and ass

ples is tha
applies, assigns a message tha

privilege of assigning messages from users to other users.  

 A user can only disable/release a rule that he crea
user belongs to an administrator group, then he is authorized to disab
any rule, even if he was not the rule creator.  Refer to View Message 
Rules. 
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CREATE/A

This actio age header(s). 

1. S c
be dis
this ru
selec

DD A MESSAGE RULE 

n applies on the mess

ele t a message and click “Pend” or “Forward”, a Pend/Forward dialog will 
played. A combo box is enabled if you check the checkbox of “Apply 
le…”  The combo lists all the message headers of the currently 

ted eCMS node.  

 

he 
s the SSN values in the message header that you are 

currently selecting, send this message directly to “User 1”. 

2. Check the checkbox to create a rule. For example, if you select one of the 
headers such as SSN, and select a user to forward the message to, say 
“User 1”, this means that “ For all existing and incoming messages, if t
message’s SSN matche

3. Click OK and the rule specified in the previous step will be applied on both 
existing and incoming messages.  

NOTE 1: There could be many cases when we can have conflicting rules. The 
application will identify only one type of rule conflicts. Rule A and B are said to be 
conflicting if both rules are identical, except that each ones tries to assign the 
message to a different user. Here is an example of two conflicting rules (rules A 
and B): Rule A= assign messages where header1=”hi” to “User1”, and Rule B= 
assign messages where header1=”hi” to “User2”. When a user tries to create a

 that conflicts with another, he will be notified and the rule will not be adde

TE 2: If you select multiple messages, the rule will pick the value of the first 
use it for matching. For example, if you choose to forward two 

 
rule d.  

NO
header and 

 
 

messages where SSN=”123A” to “User1” and the second SSN value will be 
  

messages, the first one with SSN “123A” and the second with SSN= “456B” and
try to make a rule to forward to “User1”, then the created rule will be: Assign 

ignored. 
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VIEW MESSAGE RULES 

You can view all the rules that currently exist in a certain eCMS. 

1. Select View from the Rules menu and the Rules window will be displayed to 

 if 

show all the rules for the logged on eCMS user. This will list all the rules 
each having its own check box. The checkbox is enabled if the currently 
logged user can choose to disable or release this rule. 

2. Uncheck the rule that you do not want to be applied or just leave it, as it is
you want to keep the rule. 

 

NOTE 1: A user can only disable/release a rule that he created by himself. If a 
user belongs to an administrator group, then he is authorized to disable 
even if he is not the rule creator.  

NOTE 2: When you release a rule, the current messages on which the 
rule was applied, will be released from their owners, and kept for their ori
owners (the ones who owned them before the rule was applied). 

any rule, 

disabled 
ginal 
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